Commit de1a77c1 authored by Fred Chasen's avatar Fred Chasen

Fix snapshots to work with Jest 25

parent 68d4550d
Pipeline #443 passed with stage
in 5 minutes and 28 seconds
This diff is collapsed.
......@@ -9,47 +9,47 @@
"module": "src/index.js",
"browser": "dist/paged.js",
"dependencies": {
"@babel/polyfill": "^7.8.3",
"@babel/runtime": "^7.8.4",
"@babel/polyfill": "^7.8.7",
"@babel/runtime": "^7.9.2",
"css-tree": "1.0.0-alpha.39",
"event-emitter": "^0.3.5"
},
"devDependencies": {
"@babel/cli": "^7.8.4",
"@babel/core": "^7.8.4",
"@babel/core": "^7.9.0",
"@babel/plugin-proposal-async-generator-functions": "^7.8.3",
"@babel/plugin-transform-runtime": "^7.8.3",
"@babel/preset-env": "^7.8.4",
"@babel/plugin-transform-runtime": "^7.9.0",
"@babel/preset-env": "^7.9.0",
"babel-core": "^7.0.0-bridge.0",
"babel-jest": "^25.1.0",
"chalk": "^3.0.0",
"eslint": "^6.8.0",
"express": "^4.17.1",
"ghostscript4js": "^3.1.1",
"ghostscript4js": "^3.2.1",
"jest": "^25.1.0",
"jest-image-snapshot": "^2.12.0",
"jest-image-snapshot": "^3.0.0",
"puppeteer": "^2.1.1",
"rimraf": "^3.0.2",
"rollup": "^1.31.1",
"rollup": "^2.2.0",
"rollup-plugin-commonjs": "^10.1.0",
"rollup-plugin-json": "^4.0.0",
"rollup-plugin-livereload": "^1.0.4",
"rollup-plugin-livereload": "^1.1.0",
"rollup-plugin-node-builtins": "^2.1.2",
"rollup-plugin-node-resolve": "^5.2.0",
"rollup-plugin-serve": "^1.0.1"
},
"scripts": {
"build": "./node_modules/.bin/rollup -c",
"legacy": "./node_modules/.bin/rollup -c rollup.legacy.config.js",
"start": "./node_modules/.bin/rollup -w -c rollup.server.config.js",
"build": "rollup -c",
"legacy": "rollup -c rollup.legacy.config.js",
"start": "rollup -w -c rollup.server.config.js",
"test": "npm run tests && npm run specs",
"tests": "./node_modules/.bin/jest",
"specs": "./node_modules/.bin/jest --config=specs/jest.config.js",
"compile": "./node_modules/.bin/babel src/ -d lib/",
"tests": "jest",
"specs": "jest --config=specs/jest.config.js",
"compile": "babel src/ -d lib/",
"pretest": "npm run build",
"prepublishOnly": "npm run build && npm run compile && npm run legacy",
"watch": "./node_modules/.bin/rollup -w -c",
"lint": "./node_modules/.bin/eslint -c .eslintrc.js src",
"watch": "rollup -w -c",
"lint": "eslint -c .eslintrc.js src",
"docker": "docker build -t pagedmedia/pagedjs . && docker run -it --security-opt 'seccomp=seccomp.json' -v $(pwd)/specs:/home/node/pagedjs/specs pagedmedia/pagedjs npm test"
},
"repository": {
......
const { toMatchImageSnapshot } = require('jest-image-snapshot');
const toMatchPDFSnapshot = require('./pdf_snapshot.js');
const expect = require('expect');
expect.extend({ toMatchImageSnapshot, toMatchPDFSnapshot });
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment