Commit 41ee6226 authored by Fred Chasen's avatar Fred Chasen
Browse files

Update to puppeteer v10

parent 96b8aa1f
Pipeline #855 passed with stages
in 1 minute and 29 seconds
This diff is collapsed.
......@@ -16,20 +16,20 @@
},
"main": "index.js",
"dependencies": {
"commander": "^6.1.0",
"commander": "^8.2.0",
"express": "^4.17.1",
"hyphenopoly": "^4.7.0",
"katex": "^0.12.0",
"lodash": "^4.17.20",
"mathjax": "^3.1.0",
"hyphenopoly": "^4.12.0",
"katex": "^0.13.18",
"lodash": "^4.17.21",
"mathjax": "^3.2.0",
"node-fetch": "^2.6.0",
"ora": "^5.0.0",
"pagedjs": "^0.2.0",
"pdf-lib": "0.6.4",
"puppeteer": "^5.2.1",
"puppeteer": "^10.4.0",
"replace-ext": "^2.0.0"
},
"devDependencies": {
"eslint": "^7.7.0"
"eslint": "^7.32.0"
}
}
......@@ -21,7 +21,7 @@ class Printer extends EventEmitter {
this.headless = options.headless !== false;
this.allowLocal = options.allowLocal;
this.allowRemote = options.allowRemote;
this.additionalScripts = options.additionalScripts;
this.additionalScripts = options.additionalScripts || [];
this.allowedPaths = options.allowedPaths || [];
this.allowedDomains = options.allowedDomains || [];
this.ignoreHTTPSErrors = options.ignoreHTTPSErrors;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment